Submit a ticket

Firefox Addon not compatible with latest Firefox Version 71.0

Unfortunately our Premiumize.me addon for Firefox is not compatible with the latest version for Firefox (v.71.0). The latest working version is v70.x. 

We are aware of this problem and our developers are working to fix this. We apologize for the circumstances.


General Information
You can find your customer number in your account overview
Example links help us enormously with identifying and solving download problems. Please enter them here, otherwise we will probably ask you again anyway.
Which service do you have a problem with?
Which tool, program, app did you use when the problem occurred (e.g. jDownloader, Google Chrome, OpenVPN, etc.)?
Your Message