Submit a ticket

Firefox Addon not compatible with latest Firefox Version 71.0

Unfortunately our Premiumize.me addon for Firefox is not compatible with the latest version for Firefox (v.71.0). The latest working version is v70.x. 

We are aware of this problem and our developers are working to fix this. We apologize for the circumstances.


General Information
You will find your customer number in your account overview.
Are you already a registered reseller on Premiumize.me or a new reseller?
Your Message